Helma Logo
main list history

Version 10 by simono on 29. April 2009, 11:30

20***even *** even more so if http-method-routing / REST catches on (also see http://www.w3.org/TR/REC-html40/interact/forms.html#h-17.13.1, and http://www.w3.org/Protocols/rfc2616/rfc2616-sec9.html

Version 9 by simono on 29. April 2009, 11:30

19** remove res.data. we should encourage clean seperation between POST/GET data - even more so if http-method-routing / REST catches on (also see http://www.w3.org/TR/REC-html40/interact/forms.html#h-17.13.1, and http://www.w3.org/Protocols/rfc2616/rfc2616-sec9.html data
20***even more so if http-method-routing / REST catches on (also see http://www.w3.org/TR/REC-html40/interact/forms.html#h-17.13.1, and http://www.w3.org/Protocols/rfc2616/rfc2616-sec9.html )
21*** http://dev.helma.org/trac/helma/changeset/9671

Version 8 by simono on 29. April 2009, 11:16

17* POST/GET data
18** queryParams, postParams very long. rename to smth shorter like res.GET and res.POST (uppercase would also hint their immutability)
19** remove res.data. we should encourage clean seperation between POST/GET data - even more so if http-method-routing / REST catches on (also see http://www.w3.org/TR/REC-html40/interact/forms.html#h-17.13.1, and http://www.w3.org/Protocols/rfc2616/rfc2616-sec9.html )

Version 7 by simono on 27. April 2009, 10:45

4** deprecate either count() or size(), IHopObject.forEach() should behave exactly like rhino'd prefer to deprecate count()s Array.forEach http://dev.helma.org/bugs/show_bug.cgi?id=537
5** deprecate either count() or size(), I'd prefer to deprecate count(). simon: would prefer collection.length (mimic array)

Version 6 by daniel on 06. March 2009, 10:15

9** make <strike>make getOrderedView() return something else. Currently it returns some object that is similar to a HopObject, but is not a HopObject. Some functions are missing, some throw an "unsupported exception". There should be something like a HopCollection, being extended by HopObject.</strike>

Version 5 by hannes on 19. February 2009, 12:16

Version 4 by daniel on 25. August 2008, 23:35

13* Scripting engines
14** Implement a configurable class shutter implementation for Rhino
15** Move configuration properties only influencing a specific scripting engine to it's own properties file (i.e. have separated configurations).

Version 3 by daniel on 19. August 2008, 12:05

11* Properties files
12** As every other directory or file is configurable, the location of the db.properties file should be too. I'd suggest to add dpPropsFile.

Version 2 by daniel on 05. August 2008, 17:04

10** some functions like getOrderedView() throw RuntimeExceptions when called on an incompatible (transient) HopObject, some others just return null. I propose to change all functions to throw exceptions, as one can check with isPersistent() before doing a call that might not be supported.

Version 1 by daniel on 05. August 2008, 16:51

1I am currently working on improving and extending Helma 1.x. This page serves as a public todo list summing up tasks that should be or could be done (but are no bugs) to improve Helma 1.x.
3* HopObject
4** deprecate either count() or size(), I'd prefer to deprecate count()
5** deprecate invalidate(id), as it can be done as get(id).invalidate()
6** rename the magic properties (__id__, __parent__, ...). Some properties currently exist with one underscore in front (_property) as well as with two in front and two at the end (__property__). Some only use one syntax, some are case-sensitive, some others are not.
7** move getById(id, proto) to app.getById(proto, id) or remove it as it is unrelated to the HopObject called on, leave Constructor.getById(id) as it is.
8** rename getChildElement to onGetChildElement to reflect that it is an event handler
9** make getOrderedView() return something else. Currently it returns some object that is similar to a HopObject, but is not a HopObject. Some functions are missing, some throw an "unsupported exception". There should be something like a HopCollection, being extended by HopObject.