Helma Logo
main list history
previous version  overview  next version

Version 4 by matthias on 25. June 2008, 13:20

<style>h4 <style>h3+p, h3+p+p, h3+p+p+p { margin-left: 1em } h4 { margin-left: 1em } h4+p, h4+p+p, h4+p+p+p { margin-left: 2em } h5 { margin-left: 2em } h5+p, h5+p+p, h5+p+p+p { margin-left: 3em } </style>

Currently Helma-NG ships with some modules, transfered from helma 1.x

Our goal is to open a discussion, about which modules and function should ship with helma-ng, and how they should be structured in directories and modules.

== Module Struture ==

=== Core

Core could be renamed to "lang" or "javascript" because all modules here are extending original Javascript objects. Mozilla docs refers to these objects as "Core" (Core JavaScript 1.5 Reference:Global Objects:Array:indexOf at http://developer.mozilla.org/en/docs/Core_JavaScript_1.5_Reference:Objects:Array:indexOf) in their reference. What do you think? Should we stay with "Core"? Or should we change that? (matt) +/-

==== array.js

<a href="http://www.prototypejs.org">prototype.js</a> provides a bunch of neat functions: <a href="http://www.prototypejs.org/api/enumerable">Enumerable Docs</a> and <a href="http://www.prototypejs.org/api/array">Array Docs</a>. prototype.js could be offered as a replacement or addition to the current array.js -> see <a href="https://dev.helma.org/trac/helma/browser/sandbox/aida/modules/javascript/prototype.js">/sandbox/aida/modules/javascript/prototype.js</a>

===== Array.prototype.indexOf

is part of <a href="http://developer.mozilla.org/en/docs/New_in_JavaScript_1.6">JavaScript 1.6</a> and should be removed (matt)

===== Array.prototype.lastIndexOf

is part of <a href="http://developer.mozilla.org/en/docs/New_in_JavaScript_1.6">JavaScript 1.6</a> and should be removed (matt)

===== Array.prototype.contains

works, but could be replaced by prototype.js>Enumerable>include ; see: http://www.prototypejs.org/api/enumerable/include, for compaitibility reasons we could add a conatains alias

===== Array.union

Has a bug when the source objects look similar, but are not

var obj1 = {test:"one"};
var obj2 = {test:"one"};
(obj1 != obj2) === true;
Array.union(obj1, obj2); // => [{test:"one"}]
                          //    instead of [{test:"one"}, {test:"one"}]

===== Array.intersection

not tested yet

==== date.js
==== JSON.js
==== object.js
==== string.js

=== Helma

==== skin.js
==== simpleweb.js
==== simpleweb/request.js
==== simpleweb/response.js
==== shell.js
==== rhino.js
==== logging.js
==== log4j.properties
==== jetty.xml
==== jetty.js
==== http.js
==== helma1.js
==== functional.js
==== filters.js
==== file.js
==== continuation.js
==== app.js